Dear all:

  I just summit a patch for enable frame buffer console:

  And now the GRUB debug shell and install kernelflinger do work in my local development environment.


  BR/Tan Ming.


From: Celadon [] On Behalf Of Wade Wilson
Sent: Monday, April 29, 2019 10:27 PM
Subject: Re: [ Celadon] GRUB Boot Failing To Launch Installer


A ha! That explains the blank line!


Well that certainly makes it an easier fix than what I was fearing. We just need to get the post-GRUB install text to write back to the display again. That shouldn't be a major bug to fix.


For system engineers, this is certainly a workaround. That said, for most, it's still going to be a very tall bridge to pass - especially app developers. So hopefully there is a fix soon.


On Mon, 29 Apr 2019 at 07:13, Tan, Ming <> wrote:

Dear all:

  Before the issue was fixed, the following is the work around solution:

  1. Prepare for the serial port connection, 115200,8N1.

  2. If the device has not native serial port, then use a FTDI chip based USB serial port convertor.

       a. If want to use other chip based, please modify the kernel configuration setting to add the drivers.

  3. Create the GRUB boot USB disk.

  4. Boot from GRUB boot USB disk.

  5. In GRUB menu, select ‘Install with kernelflinger’ or ‘Debug Shell’, and press key ‘E’ to modify the menu.

  6. In the detail kernel command line option, modify the ‘console=tty0’ to ‘console=ttyS0,115200n8’ or ‘console=ttyUSB0,115200n8’, and press F10 to boot.

  7. In the serial port terminal, you can see the kernel log info and install scripts information, and prompt you input something and do some selection to continue.


  I test it use my local build, and verify it in KBL NUC 7i5DNH. After install the Android, then BIOS will load GRUB, GRUB will load kernelflinger, and kernelflinger load Android, and Android can boot to UI.


  BR/Tan Ming.


From: Celadon [] On Behalf Of Tan, Ming
Sent: Monday, April 29, 2019 5:09 PM
To: Wade Wilson <>;
Subject: Re: [ Celadon] GRUB Boot Failing To Launch Installer


Dear all:

  I will have a check of why the GRUB does not work.

  But now GRUB will load kernelflinger, and kernelflinger load Android.

  After enable the Treble, GRUB load Android directly is not supported now.


  BR/Tan Ming.


From: Celadon [] On Behalf Of Wade Wilson
Sent: Monday, April 29, 2019 4:11 PM
Subject: Re: [ Celadon] GRUB Boot Failing To Launch Installer


I agree the wiki should have a note, but it should be equally for internal and external consumption. Something to the effect of “we're aware GRUB is not working properly, we understand the community needs a straightforward installer - and this will be fixed in due course.”


The whole point of GRUB + KernelFlinger was to replace IAGO as an easier solution since GRUB “just works” - so we need to rally folks to bump it back up in priority. 


The other problem is that it’s also broken on OMR1 (tried that too), so you can’t just fall back to Oreo either.


The big issue with KernelFlinger on its own, for those scratching their heads, is if you don’t have the USB host lead tool. At least with Fuchsia you can go over the network and flash. If you don’t have that lead, you can’t flash, which means you can’t bring up/boot the hardware… such as on my Kaby Lake Yoga.


My other fear is that the verified boot disable flow will break down, so if GRUB isn’t brought back up, it could create downtime issues later to not nip this in the bud and have it just work now. In other words, it could be a lot easier to do now to fix, than to fix later.


On Mon, 29 Apr 2019 at 00:41, Tapani Pälli <> wrote:

On 4/29/19 9:22 AM, Wade Wilson wrote:
> Thanks for confirming. To be clear, I don't support removing the
> instructions from the Wiki. In my watching Android-IA / Celadon over the
> years, stuff that gets removed, people jump to the conclusion there is
> no interest or need.

I understand the concern, my rationale is that all instructions what we
have there should work. If it doesn't then alternatively take it out or
at least include a clear warning that it does not work. Otherwise the
first impression will be very bad.

> For anyone in the community bringing up hardware, this is a rather
> critical need. Android is not Fuchsia, and nobody in the community is
> going to work on it without a traditional bootloader.
> I think this should get flagged as a critical bug and the bootloader
> team should fix it, ASAP with priority. GRUB should always just work.

I agree it should be fixed. Unfortunately I believe there are many other
on-going things prioritized above this so kernelflinger is considered
the "default".

> On Sun, 28 Apr 2019 at 21:42, Tapani Pälli <
> <>> wrote:
>     Hi;
>     On 4/28/19 9:47 AM, Wade Wilson wrote:
>      > Hi everyone,
>      >
>      > I am trying to get Android P up and running. I have both a Kaby Lake
>      > NUC7 and a Lenovo Yoga with Kaby Lake and stock Intel everything.
>      >
>      > I can build Celadon just fine, but when I boot the flash drive and
>      > launch GRUB, I choose the first menu item to Install with
>     KernelFlinger...
>      >
>      > ... and then hang at a blank line. Just a lone underscore and the
>     whole
>      > system hangs. No prompt to select a target drive or even some
>     crash data.
>      >
>      > I've tried both "celadon" and "cel_kbl" build targets with
>      > and project_celadon-efi ticked on during building.
>      >
>      > My NUC is running BIOS 0076 (latest) and I'm not quite sure what
>     to do
>      > here. Is GRUB broken currently? Any suggestions? Thanks!
>     Unfortunately GRUB has been broken for a long time and IMO the
>     instructions to build it should be removed from the wiki until it works
>     again. I've tried to contact some folks to remove them but it's been
>     unsuccessful :/
>     Thanks;
>     // Tapani