Thanks for confirming. To be clear, I don't support removing the instructions from the Wiki. In my watching Android-IA / Celadon over the years, stuff that gets removed, people jump to the conclusion there is no interest or need.

For anyone in the community bringing up hardware, this is a rather critical need. Android is not Fuchsia, and nobody in the community is going to work on it without a traditional bootloader.

I think this should get flagged as a critical bug and the bootloader team should fix it, ASAP with priority. GRUB should always just work.

On Sun, 28 Apr 2019 at 21:42, Tapani Pälli <tapani.palli@intel.com> wrote:
Hi;

On 4/28/19 9:47 AM, Wade Wilson wrote:
> Hi everyone,
>
> I am trying to get Android P up and running. I have both a Kaby Lake
> NUC7 and a Lenovo Yoga with Kaby Lake and stock Intel everything.
>
> I can build Celadon just fine, but when I boot the flash drive and
> launch GRUB, I choose the first menu item to Install with KernelFlinger...
>
> ... and then hang at a blank line. Just a lone underscore and the whole
> system hangs. No prompt to select a target drive or even some crash data.
>
> I've tried both "celadon" and "cel_kbl" build targets with SPARSE_IMG
> and project_celadon-efi ticked on during building.
>
> My NUC is running BIOS 0076 (latest) and I'm not quite sure what to do
> here. Is GRUB broken currently? Any suggestions? Thanks!

Unfortunately GRUB has been broken for a long time and IMO the
instructions to build it should be removed from the wiki until it works
again. I've tried to contact some folks to remove them but it's been
unsuccessful :/

Thanks;

// Tapani