On Thu, Sep 27, 2018 at 8:17 PM Kps, Harish Krupo <harish.krupo.kps@intel.com> wrote:
Hi Michael,

It would be helpful, If you could provide us with the details of the product you are working on.
In any case please find my comments in-line.

It's not a consumer device, it's a specific device that my company uses in healthcare environment. Not sure what details you want to know, but it's a baytrail platform using a N2930 CPU.
 

> So I tried Android P, but honestly, there's not much working for me:
> - boot doesn't complete, stuck on android logo: similar CommitFrame error in
> iahwcomposer (haven't tried your suggested hacks yet)

Please try out those hacks.

I will. For the record, I had tried the first one on O-MR1 and it didn't make any difference.
 
> - VA-API initialization error
> - media.codec crash (maybe related to VA-API initialization failure)
> - thermal daemon keeps restarting (probably a config problem, it seems to
> expect NUC platform)

I would suggest that you disable these in the mixins spec during bring-up. Thermal can be disabled by setting thermal: none.
I just saw that there isn't any other option for media, so just replace all the files in mixins/groups/media/project-celadon with an empty file named "empty_dir"

I can disable thermal, but disabling VA-API is not an option. That's a hard requirement (need to be able to decode 1080p). If this can't be done, then celadon is not good for me.

Thanks for the help btw.
Michael.