On 6/28/19 1:16 PM, Daniel Wagner wrote:
On 6/25/19 4:30 PM, Jussi Laakkonen wrote:
> Use vpn_agent_check_and_process_reply_error() to check and process VPN
> agent errors. Clear callback and pending D-Bus message (user_data) if
> error was processed to avoid calling the callback twice.
Patch applied. I also rename err_int to err. I think I know why you used
err_int. Was it avoid to clash with the jump label err? Luckeliy the
compiler is not confused and we got this already in our code base :)
Your assumption is correct, labels are the cause for that. I apparently
did not check if all of those plugins had a label with the "err" name
and in some of those plugins the "err_int" was not necessary.
On retrospect, another way would have been to rename the labels to
"error:" and have the int as "err". But that is just cosmetics, I just
wanted to avoid confusion :).