Hi Vasyl and Daniel,

Thank you for reviewing my patch.
I agree with Vasyl to have a dedicated structure scan_params. I will go this way.
I will also prepare changes recommended by Daniel except enum. Enum with 2 types is as bad as bool. ;-)
Daniel thank you for pointing me a flaw with PASSIVE scan. It should help me in my work as well.

PS. I am busy with my job so do not anticipate quick responses :-(

On Fri, Nov 16, 2018 at 12:19 AM Vasyl Vavrychuk <vasyl.vavrychuk@globallogic.com> wrote:
> > diff --git a/plugins/wifi.c b/plugins/wifi.c
> > index dc08c6af..ef73e843 100644
> > --- a/plugins/wifi.c
> > +++ b/plugins/wifi.c
> > @@ -1861,7 +1861,8 @@ static int wifi_scan(enum connman_service_type type,
> >                       struct connman_device *device,
> >                       const char *ssid, unsigned int ssid_len,
> >                       const char *identity, const char* passphrase,
> > -                     const char *security, void *user_data)
> > +                     const char *security, bool force_full_scan,
> > +                     void *user_data)
> I am not partucilar fan of adding a bool for this, because it is already
> hard to figure out which parameters is what. Adding a bool makes it even
> harder. Why not defining a enum for the forced scan?

How about putting ssid, ssid_len, identity, passphrase, security and
force_full_scan into scan_params structure?