Okay, I think I get your idea to streamline the naming for the
function. So, could you please just rename connman_option_get_string()
to connman_setting_get_string() and update the two call sites. And
please add a commit message why you are doing it.
Alright Daniel, I will send a new
patch following this advice in a new thread
(new commit title).