On 02/26/2019 12:24 PM, JH wrote:
> glib is not glibc. It's a portability wrapper around libc.
The error message "configure: error: GLib >= 2.28 is required" is
likely to complain glibc as aguador indicated, if that is correct, the
error message is misleading, could someone fix it?
No, this does not refer to glibc. This refers too GLib, the
capitalization should be another clue.
> On Ubuntu, the following should be sufficient:
> apt-get install libglib2.0-dev
The libglib2.0-dev has already been installed "ii libglib2.0-dev
2.56.3-0ubun amd64", it is version 2.56.3 > 2.28, that is why the
error message could not complain the glib but glibc which is 2.27-3.
But if I cannot run the configure script on Ubuntu 18.04 where the
glibc version is 2.27-3 < 2.28, how the Canonical could build ConnMan
1.35 for Ubuntu 18.04 based on glibc version 2.27 < 2.28?
Perhaps something is wrong with your environment and the configure magic
cannot find the needed pkgconfig file.