On Fri, Mar 11, 2016 at 4:29 PM, Jerry Hoemann <jerry.hoemann(a)hpe.com> wrote:
> Also let's drop the
> it's non-idiomatic with the rest of the definitions in this file.
I like field names with prefixes that refer back to the structure they're
defined in. It makes reading code easier. (e.g. how many times is
"size" defined in a struct?)
would you be okay with a prefix "nd_"? it doesn't quite tie as closely
to the struct, but it should make them unique w/in the kernel.
Isn't this leaning towards the "Hungarian notation", and isn't that
discouraged in the kernel coding style..
Encoding the type of a function into the name (so-called Hungarian
notation) is brain damaged - the compiler knows the types anyway and can
check those, and it only confuses the programmer.