On Mon, Apr 09, 2018 at 03:10:26PM -0700, Dan Williams wrote:
On Mon, Apr 9, 2018 at 1:09 PM, Ross Zwisler
> Adding on to the work started by:
> commit ebb4fb605e68 ("ndctl, create-namespace: introduce "fsdax" and
I'd say "why" here.
Because having both "memory" and "fsdax" and having to know that they
aliases is confusing. It'd be great if we could just choose one term and
stick with it, and I thought the term we had decided on was "fsdax".
Also, might as well also convert util_namespace_to_json() to emit
"fsdax" in all cases. I had initially thought there were compat
concerns with removing the "memory" designation, but it will just
cause ongoing confusion. Lets kill its output everywhere, but of
course still accept it as a command input.
Cool, I think that'd be best.