Sorry, please ignore the previous one, i mistook the problem.
The root cause is that ubuntu-18.04 only support libperl5.26 and
> Is ubuntu 18.04 not a supported distro? If it is supported, it
we will need a way to specify to install whichever version of the
package is available.
Yes, LKP supports ubuntu18.04. lkp install will read
distro/depends/unixbench to install
needed deps, packages which recorded in distro/depends/unixbench are
based on Debian9.
To solve this similar problem, you could add mapping deps to
e.g. for this case:
diff --git a/distro/adaptation/ubuntu b/distro/adaptation/ubuntu
index c7489ead..ee26e4f5 100644
@@ -14,3 +14,5 @@ libbz2-1.0:libbz2-dev
On 7/29/19 3:21 PM, Liu Yiding wrote:
Hi, John. please update lkp-tests. commit
8de082ad179f96187c37471db537068691fed355 has decreased perl to stable
On 7/25/19 10:53 PM, Allen, John wrote:
> 7cd78129d06e3c8fd47eaab4ff seems to have introduced an issue with
> The patch changes the install dependencies for ubuntu to
> perl-modules-5.28 and
> libperl5.28 from 5.26. However, ubuntu-18.04 repos seem to only
> contain version
> 5.26. Is ubuntu 18.04 not a supported distro? If it is supported, it
> seems that
> we will need a way to specify to install whichever version of the
> package is
> available. Ideally, it would be nice to be able to specify something
> "perl-modules >= 5.26", but the current method of installing packages
> seem to be equipped to handle that sort of thing.
> LKP mailing list