Build failure in the latest version has occurred with glib 2.56.4.

src/simutil.c: In function ‘validate_utf8_tlv’:
src/simutil.c:779:9: error: implicit declaration of function ‘g_utf8_validate_len’; did you mean ‘g_utf8_validate’? [-Werror=implicit-function-declaration]
  return g_utf8_validate_len((const char *)tlv + 2, len, NULL);
         ^~~~~~~~~~~~~~~~~~~
         g_utf8_validate

According to glib documentation, "g_utf8_validate_len" is supported since 2.60
So, I sent this patch.

Regards,
JongSeok Won

---
 configure.ac | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/configure.ac b/configure.ac
index d4efc8a8..f195c862 100644
--- a/configure.ac
+++ b/configure.ac
@@ -63,8 +63,8 @@ AC_CHECK_FUNC(signalfd, dummy=yes,
 AC_CHECK_LIB(dl, dlopen, dummy=yes,
  AC_MSG_ERROR(dynamic linking loader is required))
 
-PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.32, dummy=yes,
- AC_MSG_ERROR(GLib >= 2.32 is required))
+PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.60, dummy=yes,
+ AC_MSG_ERROR(GLib >= 2.60 is required))
 AC_SUBST(GLIB_CFLAGS)
 AC_SUBST(GLIB_LIBS)
 --