Hi all,

Il 05/04/2011 12.34, Claudio Degioanni ha scritto:
Il 05/04/2011 12.09, Aygon, Bertrand ha scritto:
Hi,

From what I can see when you do the 'list-modem', your modem is already enabled and online, so you do not have to do the >>./enable_modem and ./online-modem.

The PS context is also created (looking at ./list-contexts answer).

So just the ./activate-context should be fine.

But there is an error ... From what I can see in the source code, it should be enable 'post sim'. And still according to source code, >>the Huawei modem seems to skip some SIM status during warm start.

So, can you please unplug replug the USB key, wait a few, just execute ./list-modems and ./list-contexts (nothing else).
You should see the modem enabled and online, and your context created. 
If so, just execute ./activate-context
I have made the test proposed, I still recive the same error :)

I have attacched the new log of test. Ofono create the connection context, but on activation it repond with not implemented.
Sorry, I have no idea, I have try all I have in mind, but now, we need the help of someone else.

Huawei modem should support data call. The AT log looks correct. Why there is a not implemented error, I don't know...
Thanks very much for help, I have made some search on target and on ubuntu 11.04. There is a difference in product id of device, after usb modem swicth.

Target:

Bus 001 Device 001: ID 1d6b:0002 
Bus 002 Device 001: ID 1d6b:0002 
Bus 002 Device 002: ID 05e3:0608 
Bus 002 Device 003: ID 0951:1653 
Bus 002 Device 004: ID 2001:3c05 
Bus 002 Device 005: ID 12d1:1436 
Bus 003 Device 001: ID 1d6b:0002

Ubuntu:

Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 003: ID 0a5c:2110 Broadcom Corp. Bluetooth Controller
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 004: ID 050d:5055 Belkin Components F5D5055 Gigabit Network Adapter [AX88xxx]
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 007: ID 12d1:140c Huawei Technologies Co., Ltd.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I have made some test on target, and now I'm able to swicth the modem to correct device type

Bus 001 Device 007: ID 12d1:140c Huawei Technologies Co., Ltd.

But I still have the problem to activate the 3G connection, i have attacched the new log of my test.

Any suggestion ?

regs claudio