Versions,
ofono 1.16
connman 1.28
I updated connman to 1.31, but din not make any difference.

Logs do not show any problems, but it seems that there is something wrong - for instance:
These are now connman commands, but really I don't now find difference, ofono seems now more or less integrated to connman. But it is fine to forward me to connman mailing list as any feedback at all is fine..

> connmanctl connect cellular_244052161781216_context1
Error /net/connman/service/cellular_244052161781216_context1: Input/output error

> connmanctl config cellular_244052161781216_context1 --autoconnect yes
Error cellular_244052161781216_context1: Invalid service

Thanks,
Matti

2015-12-30 12:31 GMT+02:00 matti kaasinen <matti.kaasinen@gmail.com>:
Hi!

Have anyone managed using newer version of Huawei 3131 (idVendor=12d1, idProduct=14fe pair) together with connman/ofono?

Older version of Huawei 3131 registered nicely with cdc_ether and was shown as wired service and connected automatically with eth1 interface.

------------------
Modeswitch:
------------------
seems noticing modem as idVendor=12d1, idProduct=1506 device.

-------------------------------------------------------------
Connman seems creating wwan0 interface
-------------------------------------------------------------
connmand[349]: wwan0 {create} index 3 type 1 <ETHER>
connmand[349]: wwan0 {update} flags 4098 <DOWN>
connmand[349]: wwan0 {newlink} index 3 address 58:2C:80:13:92:63 mtu 1500
connmand[349]: wwan0 {newlink} index 3 operstate 2 <DOWN>
connmand[349]: Adding interface wwan0 [ cellular ]

-----------
usbcore:
-----------
usbcore: registered new interface driver usbserial
usb-storage 2-1:1.5: USB Mass Storage device detected
usbcore: registered new interface driver cdc_ncm
usbcore: registered new interface driver cdc_wdm
usbcore: registered new interface driver option

-------------------------
huawei_cdc_ncm:
--------------------------
huawei_cdc_ncm 2-1:1.1 wwan0: register 'huawei_cdc_ncm' at usb-musb-hdrc.1.auto-1, Huawei CDC NCM device, 58:2c:80:13:92:63

-------------------------
usbserial:
--------------------------
usbserial: USB Serial support registered for GSM modem (1-port)
usb 2-1: GSM modem (1-port) converter now attached to ttyUSB0
usb 2-1: GSM modem (1-port) converter now attached to ttyUSB1
usb 2-1: GSM modem (1-port) converter now attached to ttyUSB2

-------------------------
ofono:
--------------------------
Modem and NDIS support (CDC support: NDIS port)

Besides /dev/ttyUSBx ports there also exists /dev/cdc-wdm0

Modem shows up with connmanctl technologies 
/net/connman/technology/cellular
  Name = Cellular
  Type = cellular
  Powered = False
  Connected = False
  Tethering = False

But it does not show as service

It is required to make manual online-modem ofono test command to get cellular technology powered. Then it is also shown as service. Also fast blinking green sign switches to slow blinking blue sign.

However, no interfaces are shown with ifconfig command nor any connection is made when etherenet is unplugged.

Also no proggress is shown when
connmanctl session connect --type cellular
is made.

Do anyone know what I miss?

Thanks,
Matti

If so, what kernel modules should I have present?