On Wed, Jul 16, 2014 at 2:43 PM, Patrick Ohly <patrick.ohly@intel.com> wrote:
On Wed, 2014-07-16 at 08:40 +0800, Emfox Zhou wrote:
>
> On Jul 16, 2014 2:12 AM, "Patrick Ohly" <patrick.ohly@intel.com>
> wrote:
> >
> > I'm starting to suspect that you run into temporary requests by
> Google
> > to log into their web form. SyncEvolution should work around that by
> > resending requests with plain authentication.
> >
> > In your second sync output from two emails ago, the sync did proceed
> to
> > the "download data" phase and the only unusual output were INFO
> > messages, not ERRORs:
> >
> > [INFO] sync: /org/syncevolution/Session/15756214181405429789:
> operation
> > temporarily (?) failed, going to retry in 4.8s before giving up in
> > 299.8s: GET: Neon error code 3 = NE_AUTH, HTTP status 401: Could not
> > authenticate to server: ignored GoogleLogin challenge
> >
> > How did that sync end? Successfully or with a failure?
>
> Failure, the phone end up while the progress reached 6% and say
> "connection not usable", the server just repeatedly output the
> "temporarily (?) failed....." line hundred of times every several
> seconds, as every other time before.

So the retry mechanism works and the password is okay, the problem
"merely" is that it slows down the sync too much and the phone gives up.

I don't know when or why Google decides to issue a 401. What you can try
is to reduce the time that SyncEvolution sleeps between requests. For
that, set retryInterval:
        syncevolution --configure retryInterval=1s c102

I tried, but all the same errors, nothing changed.
 
It would be possible to reduce the number of GETs, but that would
require changing the source code.

> > Google stopped supporting plain text authentication. At some point
> > you'll have to get OAuth-based authentication working; unfortunately
> > that is not easy on a headless server.
>
> I have a big news, I tried another google account, this method works
> as a charm, all the contacts are synced,and my google app account,
> also works. from now on, 3 of other google accounts are all ok with
> the sync, but only not my main account. I try to find some different
> setting between my main account and other account, especially those
> security settings, but nothing useful found.  The only difference I
> can say is that the main account is registered long before (about
> 2006), and the others are later (between 2011 and 2014).

Do they have the same amount of contacts?

I always suspected that Google issues the 401 to throttle traffic,
because normally it would cause clients to pop up a password dialog.

 
Not that more, my main account has more than 900 contacts, and others
has less the 20. I started to sync new contacts into another account, the
syncing was stopped by server every 35 or 47 contacts or so, I restarted
the process several times, and when the contacts reached 190, the same
error of my main google account appeared.

What a pity, does this mean I should dispose my old phone into trash? ...


--
Emfox Zhou

GnuPG Public Key: 0xF7142EC2