Wednesday 30 of December 2015 22:14:03 Patrick Ohly:

> On Wed, 2015-12-30 at 15:47 +0100, Janusz wrote:

> > ... and freezes on this not presenting Akonadi resources (akonadi

> > runs). Seems like syncevo-dbus-helper (invoked by syncevo-dbus-server)

> > stopped responding with no error.

>

> That looks like a problem with using Akonadi from the SyncEvolution

> daemon.

>

> Can you check whether it works entirely in the command line process? For

> that, use:

> SYNCEVOLUTION_DEBUG=1 syncevolution loglevel=3 --print-databases --daemon=no

> > ======== sys info ==================================================

> >

> > $ syncevolution --version

> > SyncEvolution 1.5

>

> That's a SyncEvolution binary from syncevolution.org?

 

On 1st PC no - from distro. On 2nd one from syncevolution.org but I need to do a trick becauce of unmet dependencies: libpcrecpp0

 

Distro has libpcrecpp0v5 but the other app uses it so I cannot remove it.

I did a trick and changed dependencies in syncevolutio-baundle to use v5 version but final result is exactly the same.

 

======== sys info - 2nd PC ===========

$ syncevolution --version
SyncEvolution 1.5.1
using libical.so.1
using libical.so.1
using libbluetooth.so.3
Loading backend library /usr/lib/syncevolution/backends/syncxmlrpc.so
Loading backend library /usr/lib/syncevolution/backends/syncsqlite.so
Loading backend library /usr/lib/syncevolution/backends/syncqtcontacts.so
Loading backend library /usr/lib/syncevolution/backends/syncpbap.so
Loading backend library /usr/lib/syncevolution/backends/syncmaemocal.so
Loading backend library /usr/lib/syncevolution/backends/synckcalextended.so
Loading backend library /usr/lib/syncevolution/backends/syncfile.so
Loading backend library /usr/lib/syncevolution/backends/syncecal-6.so
Loading backend library /usr/lib/syncevolution/backends/syncebook-4.so
Loading backend library /usr/lib/syncevolution/backends/syncdav.so
Loading backend library /usr/lib/syncevolution/backends/syncakonadi.so
Loading backend library /usr/lib/syncevolution/backends/provideruoa-2.so
Loading backend library /usr/lib/syncevolution/backends/providergoa.so
Loading backend library /usr/lib/syncevolution/backends/platformkde.so
Loading backend library /usr/lib/syncevolution/backends/platformgnome.so

>

> > $ cat /etc/lsb-release

> > DISTRIB_ID=Ubuntu

> > DISTRIB_RELEASE=15.10

> > DISTRIB_CODENAME=wily

> > DISTRIB_DESCRIPTION="Ubuntu 15.10"

>

> I think a C++ ABI change went into that distro. I have not checked how

> that affects SyncEvolution binaries, in particular regarding KDE +

> Akonadi.

 

Should I try to downgrade something ?