On Tue, Jul 15, 2014 at 1:59 AM, Patrick Ohly <patrick.ohly@intel.com> wrote:

Thanks for pointing out that these are two different commands. I missed
that.

To me it looks like you accidentally configured "addressbook" in your
@default context to use Google CardDAV. Otherwise the second step would
not attempt to contact any server.

There's no command to remove sources, so if you don't have anything else
configured in the default context, then remove it completely with:
  syncevolution --remove @default

Then run the second command again.

 
Now it complains for the missing DBus server or so, either I should recompile
syncevolution without dbus or ensure the dbus is running, I don't want to deal
with these things... OK so let's jump to the main part, my main reason to play
with syncevolution is to sync my old nokia c1-02 (which is an s40 system) with
my google contact. I read through the manual and learned that the bridge mode
from SyncML to WebDAV is for me, and I needn't care about these local
storage, am I right?

so I use these configuration:

syncevo-http-server http://localhost:9000/ --start-dbus-session &

syncevolution --configure --sync-property syncURL= \
   --sync-property peerIsClient=1 \
   --sync-property remoteDeviceId="IMEI:xxxxxxxxxxx" \
   --sync-property username=emfox \
   --sync-property password=111 \
   --sync-property SSLVerifyServer=0 \
   --source-property uri= \
   --source-property sync=none \
   c102

syncevolution --configure --source-property backend=carddav \
   --source-property databaseUser=emfoxzhou@gmail.com \
   --source-property databasePassword=jlxxxxxxxxxxxxxdlv \ 
    c102 addressbook

syncevolution --configure --sync two-way c102 addressbook 

After that, I started syncing from my phone, using param 
server "http://myserver.com:9000/"
username "emfox"
password "111"
contact "addressbook"

then the console on my computer was full of:

[INFO] sync: /org/syncevolution/Session/19854541911405391636: operation temporarily (?) failed, going to retry in 4.9s before giving up in 299.9s: GET: Neon error code 3 = NE_AUTH, HTTP status 401: Could not authenticate to server: ignored GoogleLogin challenge
[INFO] sync: /org/syncevolution/Session/19854541911405391636: operation temporarily (?) failed, going to retry in 4.9s before giving up in 299.9s: GET: Neon error code 3 = NE_AUTH, HTTP status 401: Could not authenticate to server: ignored GoogleLogin challenge
[INFO] sync: /org/syncevolution/Session/19854541911405391636: operation temporarily (?) failed, going to retry in 4.9s before giving up in 299.9s: GET: Neon error code 3 = NE_AUTH, HTTP status 401: Could not authenticate to server: ignored GoogleLogin challenge

Please check if I missed anything. I was sure the password is ok, because
you see I just configured a target-config that connected to google correctly.


--
Emfox Zhou

GnuPG Public Key: 0xF7142EC2