Connman-0.67 Crashes and/or Hangs on Start-up

Samuel Ortiz sameo at linux.intel.com
Fri Jan 28 16:51:31 PST 2011


Hi Grant,

On Fri, Jan 28, 2011 at 02:52:36PM -0800, Grant Erickson wrote:
> On Jan 28, 2011, at 10:09 AM, Grant Erickson wrote:
> > On Jan 28, 2011, at 9:44 AM, Samuel Ortiz wrote:
> >> On Fri, Jan 28, 2011 at 09:06:12AM -0800, Grant Erickson wrote:
> >>> FYI. I need to check against GIT top-of-tree and dig into this further; however, with:
> >>> 
> >>> 	* Wireless 802.11 WEXT, connman-0.67 hangs on start-up
> >>> 
> >>> Backtrace with wired:
> >> 
> >> Please give us a gdb backtrace or run test/backtrace src/connmand <log> where
> >> log is the below trace.
> >> 
> >> Also, a connman -d -n log would be more useful.
> 
> Samuel:
> 
> With the wired Ethernet issue debugged and patched, I've done more investigation on the wireless issue. The results are as follows:
> 
> 	------------------------------------------------------
> 	Version / Plugin	wifi.so		wifi_legacy.so
>         ======================================================
> 	connman-0.67		FAILS		SUCCEEDS
> 	------------------------------------------------------
> 	connman-b1db3cb		FAILS		N/A
>         ======================================================
> 
> So, it would appear that the non-legacy wifi plugin has issues with wireless extension devices.
> 
I'm testing this with my iwlagn chipset forced to run in wext mode only and
that seems to work fine.

Would you mind sharing the output of wpa_supplicant -ddd -t -u when running
connmand on top of it ? Also could you please show us what your wpa_supplicant
.config look like ?

Cheers,
Samuel.

-- 
Intel Open Source Technology Centre
http://oss.intel.com/



More information about the connman mailing list