Connman-0.67 Crashes and/or Hangs on Start-up

Kalle Valo kalle.valo at canonical.com
Sun Jan 30 01:52:29 PST 2011


Hi Grant,

Grant Erickson <marathon96 at gmail.com> writes:

> Between you and Samuel, it's good to hear that both the Atheros AR242x and
> Intel IWLAGN work well with 0.68/b1db3cb under wireless extensions with the
> non-legacy Wi-Fi plug-in. Would I be correct in assuming that both you and
> Samuel are using a Core iX or Atom platform? Against what kernel version are
> you running?
>
> In my case, it's linux-2.6.32, armv7l and TI WLAN 127x, their TIWLAN WiLink
> 6.1.0.2.144 driver and firmware 6.1.0.0.335.

TI's WiLink driver might behave oddly and simply have bugs in it's wext
interface. I strongly recommend to use the proper upstream driver
wl12xx:

http://linuxwireless.org/en/users/Drivers/wl12xx

In the long run you will save a lot of trouble. For example, it will
work with wpasupplicant and connman out of box, thanks to mac80211
stack. Out-of-tree drivers are always pain, avoid them like the plague.

-- 
Kalle Valo



More information about the connman mailing list