Wifi Technology says its offline when wifi dongle is unplugged and plugged back in

Sameer Naik sameer.subscriptions at damagehead.com
Sat Feb 18 23:40:15 PST 2012


Hi,

if i connect a usb wifi dongle and start connman and query the wifi
technology as so:

----------
$ dbus-send --system --print-reply --dest=net.connman /net
/connman/technology/wifi net.connman.Technology.GetProperties.
$ dbus-send --system --print-reply --dest=net.connman /net
/connman/technology/wifi net.connman.Technology.GetProperties
method return sender=:1.172 -> dest=:1.174 reply_serial=2
   array [
      dict entry(
         string "State"
         variant             string "enabled"
      )
      dict entry(
         string "Name"
         variant             string "WiFi"
      )
      dict entry(
         string "Type"
         variant             string "wifi"
      )
      dict entry(
         string "Tethering"
         variant             boolean false
      )
   ]
-------------

It lists that the state of the wifi technology is "enabled".  When i
remove the wifi dongle the Technology it says its "offline"

But when i plug the dongle back in, it remains "offline" and does not
go to "enabled". However, if i get the manager properties using:

$ dbus-send --system --print-reply --dest=net.connman  /
net.connman.Manager.GetProperties, wifi is listed under enabled
technologies.

so in short, Manager says technology is "enabled", while Technology
says its "offline". Is this the expected behaviour?

Regards
~Sameer



More information about the connman mailing list