Wifi Technology says its offline when wifi dongle is unplugged and plugged back in

alok barsode alokbarsode at gmail.com
Tue Feb 21 11:45:50 PST 2012


Hi Sameer,

On Tue, Feb 21, 2012 at 8:14 PM, Sameer Naik <
sameer.subscriptions at damagehead.com> wrote:

> Hello,
>
> I seems that the technology state is not updated correctly.
> When i start connman and by ethernet connection is up and system is
> online, The ethernet technology says "enabled". I think it should be
> saying connected.
>
> For wifi, when the dongle is removed the State goes to offline. But on
> plugging it back in, it never goes to the enabled or connected states.
> This is until connman is relaunched.
>
> Is this a bug? or am i not understanding it right!
>
> what version of connman are u using ? we have moved to Powered and
Connected properties for technology. I think you seem to be using a older
version by what you are reporting.
here is what i get when I do a GetPropreties on wifi

dbus-send --system --print-reply --dest=net.connman
/net/connman/technology/wifi net.connman.Technology.GetProperties
method return sender=:1.101 -> dest=:1.153 reply_serial=2
   array [
      dict entry(
         string "Name"
         variant             string "WiFi"
      )
      dict entry(
         string "Type"
         variant             string "wifi"
      )
      dict entry(
         string "Powered"
         variant             boolean true
      )
      dict entry(
         string "Connected"
         variant             boolean true
      )
      dict entry(
         string "Tethering"
         variant             boolean false
      )
   ]




> Regards
> ~Sameer
>
>
> Cheers,
Alok.

> On Sun, Feb 19, 2012 at 1:10 PM, Sameer Naik
> <sameer.subscriptions at damagehead.com> wrote:
> > Hi,
> >
> > if i connect a usb wifi dongle and start connman and query the wifi
> > technology as so:
> >
> > ----------
> > $ dbus-send --system --print-reply --dest=net.connman /net
> > /connman/technology/wifi net.connman.Technology.GetProperties.
> > $ dbus-send --system --print-reply --dest=net.connman /net
> > /connman/technology/wifi net.connman.Technology.GetProperties
> > method return sender=:1.172 -> dest=:1.174 reply_serial=2
> >   array [
> >      dict entry(
> >         string "State"
> >         variant             string "enabled"
> >      )
> >      dict entry(
> >         string "Name"
> >         variant             string "WiFi"
> >      )
> >      dict entry(
> >         string "Type"
> >         variant             string "wifi"
> >      )
> >      dict entry(
> >         string "Tethering"
> >         variant             boolean false
> >      )
> >   ]
> > -------------
> >
> > It lists that the state of the wifi technology is "enabled".  When i
> > remove the wifi dongle the Technology it says its "offline"
> >
> > But when i plug the dongle back in, it remains "offline" and does not
> > go to "enabled". However, if i get the manager properties using:
> >
> > $ dbus-send --system --print-reply --dest=net.connman  /
> > net.connman.Manager.GetProperties, wifi is listed under enabled
> > technologies.
> >
> > so in short, Manager says technology is "enabled", while Technology
> > says its "offline". Is this the expected behaviour?
> >
> > Regards
> > ~Sameer
> _______________________________________________
> connman mailing list
> connman at connman.net
> http://lists.connman.net/listinfo/connman
>



More information about the connman mailing list