[pacrunner PATCH 0/2] Autostart and library version fixes

Patrik Flykt patrik.flykt at linux.intel.com
Tue Sep 3 23:48:20 PDT 2013


	Hi,

By changing the libtool library version to 1:1:1, it will be possible to
also support libproxy 0.3 and not just version 0.4. At least according to
the documentation at
http://www.gnu.org/software/libtool/manual/html_node/Libtool-versioning.html
With revision (the second argument) set to 1, pacrunner's version should
always be used even with either of the original versions installed.

Autostart was relying on a path, but that seems not to work as expected.
Just changing the rule to send_destination does the trick.

Someone with libproxy 0.4 should test, with these modifications I get
autostart working with libproxy 0.3.

Cheers,

	Patrik


Patrik Flykt (2):
  pacrunner: Fix pacrunner autostart
  build: Be compatible with libproxy 0.3 library

 Makefile.am        |    2 +-
 src/pacrunner.conf |    2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

-- 
1.7.10.4




More information about the connman mailing list