Tethering question

Jukka Rissanen jukka.rissanen at gmail.com
Sat Sep 7 01:59:39 PDT 2013


Hi Gary,

On 7 September 2013 01:07, Gary Oliver <go at ao-cs.com> wrote:
> I'm using that release (5619eb9df7a07a0e8274636eb240e7864ea9c602)
>
> My software is using the DBus interfaces (via a python script.) The
> test-connman scripts have the same issues.

Ok, that rules out API misuse.

>
> I'm currently using a BeagleBone "white" platform :-).  Have a 'black' but
> need to do some stuff before I port my app hardware to it.  The connman
> in the current Angstrom release is 1.4 (at least that's the last one when I
> pulled the Angstrom tree.)  Way too old for my purposes, so I'm using a
> custom recipe to build 1.18 (and previously 1.13)
>
> I've started down the debug path, and it sure looks like the error is coming
> from a "Not Supported: return when setting "Tethering = 1".  If I try
> setting
> Tethering = 0, it receive an "Already Disabled" return, so the next thing in
> sequence is a is a call to set_tethering() around line 873 of
> src/technology.c.
>
> set_tethering() appears to fail due to not finding the 'tether' bridge,
> which was
> destroyed when last "Tethering = 0" was set.

It looks like the issues are outside of connman. Are you using old
wext wifi driver, we have seen issues with it. Also make sure that all
the necessary kernel options are enabled, check README file, it should
have now proper options documented.

>
> I'm about to turn on full DBG and see what lands in the log files..
>
> I'd definitely appreciate your input after you check it out on the 'black.'

I tried with Beaglebone Black and everything worked just fine for me.

>
> Thanks for the help,
> -Gary


Cheers,
Jukka



More information about the connman mailing list